const regex = /([\da-zA-Z_-]+)@([\da-zA-Z_-]+).([\da-zA-Z_-]{2,6})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\da-zA-Z_-]+)@([\\da-zA-Z_-]+).([\\da-zA-Z_-]{2,6})?', 'g')
const str = `em9ail_name@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}