$re = '/^data:.*;base64,.*/';
$str = 'data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABCkAAAQpCAYAAADs9ld';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);