using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^data:.*;base64,.*";
string input = @"data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABCkAAAQpCAYAAADs9ld";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}