package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^data:.*;base64,.*`)
var str = `data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABCkAAAQpCAYAAADs9ld`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}