re = /^[A-Za-z.]{3,30}$/m
str = 'himanshubajaj
snoobajaj
dr.snehabajaj
sneha2026@
HIM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end