package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z.]{3,30}$`)
var str = `himanshubajaj
snoobajaj
dr.snehabajaj
sneha2026@
HIM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}