$re = '/^[A-Za-z.]{3,30}$/m';
$str = 'himanshubajaj
snoobajaj
dr.snehabajaj
sneha2026@
HIM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);