re = /http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*/m
str = 'http://google.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end