package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*`)
var str = `http://google.com/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}