$re = '/http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*/m';
$str = 'http://google.com/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);