import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<protocol>s?ftp):\\/\\/(?:(?<user>[^@\\s]+)@)?(?<host>[^\\?\\s\\:]+)(?:\\:(?<port>[0-9]+))?(?:\\?(?<password>.+))?";
final String string = "ftp://anonymous@example.net:21\n"
+ "ftp://wearenaive.net\n"
+ "ftp://127.0.0.1\n"
+ "sftp://authenticatedUser@securesite.com:558?password";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}