#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?"
Local $sString = "ftp://anonymous@example.net:21" & @CRLF & _
"ftp://wearenaive.net" & @CRLF & _
"ftp://127.0.0.1" & @CRLF & _
"sftp://authenticatedUser@securesite.com:558?password"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")