package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?`)
var str = `ftp://anonymous@example.net:21
ftp://wearenaive.net
ftp://127.0.0.1
sftp://authenticatedUser@securesite.com:558?password`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}