re = /(?:.*?\d{5}){3}.*?(\d{5})/
str = '49237 47387 48234 34567 34566 23456 23456'
# Print the match result
str.match(re) do |match|
puts match.to_s
end