$re = '/(?:.*?\d{5}){3}.*?(\d{5})/s';
$str = '49237 47387 48234 34567 34566 23456 23456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);