const regex = /(?:.*?\d{5}){3}.*?(\d{5})/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?\\d{5}){3}.*?(\\d{5})', 's')
const str = `49237 47387 48234 34567 34566 23456 23456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}