re = /^org.apache.jackrabbit.vault.packaging.impl.ActivityLog\s(?<package_group>.*?)\:(?<package_name>.*?)\:((?P<package_version>.*)\:\sINSTALL|\sINSTALL)/m
str = 'org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:INC1664321_HeaderIssueChanges: INSTALL
org.apache.jackrabbit.vault.packaging.impl.ActivityLog Aldi Content Package Group:aldi-aem.acl-configuration:2022.307.1144904.0001129077: INSTALL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end