#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^org.apache.jackrabbit.vault.packaging.impl.ActivityLog\s(?<package_group>.*?)\:(?<package_name>.*?)\:((?P<package_version>.*)\:\sINSTALL|\sINSTALL)"
Local $sString = "org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:INC1664321_HeaderIssueChanges: INSTALL" & @CRLF & _
"org.apache.jackrabbit.vault.packaging.impl.ActivityLog Aldi Content Package Group:aldi-aem.acl-configuration:2022.307.1144904.0001129077: INSTALL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")