// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$|^([a-zA-Z]{1,2}\d{1,2})$").unwrap();
let string = "WR56GH";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}