#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$|^([a-zA-Z]{1,2}\d{1,2})$"
Local $sString = "WR56GH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")