re = /^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$|^([a-zA-Z]{1,2}\d{1,2})$/i
str = 'WR56GH'
# Print the match result
str.match(re) do |match|
puts match.to_s
end