# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-\s(.*)\n?"
test_str = ("- Abonnement Standard\n"
"- Support Standard\n"
"- 2 Canaux\n\n"
"- Définition de la stratégie de ciblage par un chef de produit dédié\n"
"- Suivi mensuel des performances et optimisation de la stratégie de ciblage \n"
"- Configuration et intégration\n"
"- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive\n"
"- Formation à distance - 2 heures - 5 personnes\n"
"- Option Genius Targeting\n"
"- Option Genius Answers")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.