use strict;
my $str = '- Abonnement Standard
- Support Standard
- 2 Canaux
- Définition de la stratégie de ciblage par un chef de produit dédié
- Suivi mensuel des performances et optimisation de la stratégie de ciblage
- Configuration et intégration
- Personnalisation de l\'intégration graphique (2 allers-retours) - Option Responsive
- Formation à distance - 2 heures - 5 personnes
- Option Genius Targeting
- Option Genius Answers';
my $regex = qr/-\s(.*)\n?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}