#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)-\s(.*)\n?"
Local $sString = "- Abonnement Standard" & @CRLF & _
"- Support Standard" & @CRLF & _
"- 2 Canaux" & @CRLF & _
"" & @CRLF & _
"- Définition de la stratégie de ciblage par un chef de produit dédié" & @CRLF & _
"- Suivi mensuel des performances et optimisation de la stratégie de ciblage " & @CRLF & _
"- Configuration et intégration" & @CRLF & _
"- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive" & @CRLF & _
"- Formation à distance - 2 heures - 5 personnes" & @CRLF & _
"- Option Genius Targeting" & @CRLF & _
"- Option Genius Answers"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")