$re = '/R921|ESV005E|ESV004E|ESV003E/';
$str = 'M230ESV00E';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);