const regex = /R921|ESV005E|ESV004E|ESV003E/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('R921|ESV005E|ESV004E|ESV003E', '')
const str = `M230ESV00E`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}