using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R921|ESV005E|ESV004E|ESV003E";
string input = @"M230ESV00E";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}