$re = '/(?(DEFINE)(?<hours>[0-2]\d{1})(?<minutes>[0-5]\d{1})(?<seconds>(?&minutes))(?<milliseconds>\d{3})(?<separator>\-\-\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\.(?&milliseconds)))^(?<start>(?&timecode))\ {1,}-->\ {1,}(?<end>(?&timecode))(.*)$/';
$str = '00:59:59.100 --> 00:00:00.000asdasdasdkjsdkjfhsdkjgfhdkfjhglaksjd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);