// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?(DEFINE)(?<hours>[0-2]\d{1})(?<minutes>[0-5]\d{1})(?<seconds>(?&minutes))(?<milliseconds>\d{3})(?<separator>\-\-\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\.(?&milliseconds)))^(?<start>(?&timecode))\ {1,}-->\ {1,}(?<end>(?&timecode))(.*)$").unwrap();
let string = "00:59:59.100 --> 00:00:00.000asdasdasdkjsdkjfhsdkjgfhdkfjhglaksjd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}