const regex = /(?(DEFINE)(?<hours>[0-2]\d{1})(?<minutes>[0-5]\d{1})(?<seconds>(?&minutes))(?<milliseconds>\d{3})(?<separator>\-\-\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\.(?&milliseconds)))^(?<start>(?&timecode))\ {1,}-->\ {1,}(?<end>(?&timecode))(.*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<hours>[0-2]\\d{1})(?<minutes>[0-5]\\d{1})(?<seconds>(?&minutes))(?<milliseconds>\\d{3})(?<separator>\\-\\-\\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\\.(?&milliseconds)))^(?<start>(?&timecode))\\ {1,}-->\\ {1,}(?<end>(?&timecode))(.*)$', 'g')
const str = `00:59:59.100 --> 00:00:00.000asdasdasdkjsdkjfhsdkjgfhdkfjhglaksjd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}