import Foundation
let pattern = ##"(#{1,6})\ h[1-6](\ \1)?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #######"""
# h1
## h2
### h3
#### h4
##### h5
###### h6
# h1 #
## h2 ##
### h3 ###
#### h4 ####
##### h5 #####
###### h6 ######
"""#######
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)