const regex = /(#{1,6})\ h[1-6](\ \1)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#{1,6})\\ h[1-6](\\ \\1)?', 'g')
const str = `# h1
## h2
### h3
#### h4
##### h5
###### h6
# h1 #
## h2 ##
### h3 ###
#### h4 ####
##### h5 #####
###### h6 ######`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}