$re = '/(#{1,6})\ h[1-6](\ \1)?/';
$str = '# h1
## h2
### h3
#### h4
##### h5
###### h6
# h1 #
## h2 ##
### h3 ###
#### h4 ####
##### h5 #####
###### h6 ######';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);