import Foundation
let pattern = #"(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd
F O R T N I T E
Fgfdg
Ofdsgfdsg
Rfsdgfdsgf
Tdsgfsdgf
Nsdgfsdgf
Idsgfsdgfds
Tfsdgfdgf
Esgfsgfsd
FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE
F.O.R.T.N.I.T.E
// In the original string before the regex check, leet speak numbers can be replaced with letters.
f0rtn1t3
// After writing the "comment" above, I found that it matched "Fornite" in it and realized the monster I had created.
// Please help me.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)