const regex = /(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(f(.*)?(\\s)?o(.*)?(\\s)?r(.*)?(\\s)?t(.*)?(\\s)?n(.*)?(\\s)?i(.*)?(\\s)?t(.*)?(\\s)?e)', 'gm')
const str = `fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd
F O R T N I T E
Fgfdg
Ofdsgfdsg
Rfsdgfdsgf
Tdsgfsdgf
Nsdgfsdgf
Idsgfsdgfds
Tfsdgfdgf
Esgfsgfsd
FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE
F.O.R.T.N.I.T.E
// In the original string before the regex check, leet speak numbers can be replaced with letters.
f0rtn1t3
// After writing the "comment" above, I found that it matched "Fornite" in it and realized the monster I had created.
// Please help me.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}