import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(f(.*)?(\\s)?o(.*)?(\\s)?r(.*)?(\\s)?t(.*)?(\\s)?n(.*)?(\\s)?i(.*)?(\\s)?t(.*)?(\\s)?e)";
final String string = "fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd\n\n"
+ "F O R T N I T E\n\n"
+ "Fgfdg\n"
+ "Ofdsgfdsg\n"
+ "Rfsdgfdsgf\n"
+ "Tdsgfsdgf\n"
+ "Nsdgfsdgf\n"
+ "Idsgfsdgfds\n"
+ "Tfsdgfdgf\n"
+ "Esgfsgfsd\n\n"
+ "FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE\n\n"
+ "F.O.R.T.N.I.T.E\n\n"
+ "// In the original string before the regex check, leet speak numbers can be replaced with letters.\n"
+ "f0rtn1t3\n"
+ "// After writing the \"comment\" above, I found that it matched \"Fornite\" in it and realized the monster I had created.\n"
+ "// Please help me.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}