# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https:\/\/www.test.com\/(en|de|fr|es|pt-br)\/((blog|news|nouvelles|noticias))+([a-zA-Z0-9-\/]*)$"
test_str = ("Should be excluded - starting page:\n"
"https://www.test.com/en/\n"
"https://www.test.com/de/\n"
"https://www.test.com/fr/\n"
"https://www.test.com/es/\n"
"https://www.test.com/pt-br/\n\n"
"Should be excluded - pages and sub pages from blog and news:\n"
"https://www.test.com/en/blog\n"
"https://www.test.com/en/news\n"
"https://www.test.com/en/noticias\n"
"https://www.test.com/en/nouvelles\n"
"https://www.test.com/en/blog/hardware\n"
"https://www.test.com/en/news/hardware\n\n"
"Should be included - all other pages:\n"
"https://www.test.com/en/shop\n"
"https://www.test.com/en/shop/product-1/\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.