#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/www.test.com\/(en|de|fr|es|pt-br)\/((blog|news|nouvelles|noticias))+([a-zA-Z0-9-\/]*)$"
Local $sString = "Should be excluded - starting page:" & @CRLF & _
"https://www.test.com/en/" & @CRLF & _
"https://www.test.com/de/" & @CRLF & _
"https://www.test.com/fr/" & @CRLF & _
"https://www.test.com/es/" & @CRLF & _
"https://www.test.com/pt-br/" & @CRLF & _
"" & @CRLF & _
"Should be excluded - pages and sub pages from blog and news:" & @CRLF & _
"https://www.test.com/en/blog" & @CRLF & _
"https://www.test.com/en/news" & @CRLF & _
"https://www.test.com/en/noticias" & @CRLF & _
"https://www.test.com/en/nouvelles" & @CRLF & _
"https://www.test.com/en/blog/hardware" & @CRLF & _
"https://www.test.com/en/news/hardware" & @CRLF & _
"" & @CRLF & _
"Should be included - all other pages:" & @CRLF & _
"https://www.test.com/en/shop" & @CRLF & _
"https://www.test.com/en/shop/product-1/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")