using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/www.test.com\/(en|de|fr|es|pt-br)\/((blog|news|nouvelles|noticias))+([a-zA-Z0-9-\/]*)$";
string input = @"Should be excluded - starting page:
https://www.test.com/en/
https://www.test.com/de/
https://www.test.com/fr/
https://www.test.com/es/
https://www.test.com/pt-br/
Should be excluded - pages and sub pages from blog and news:
https://www.test.com/en/blog
https://www.test.com/en/news
https://www.test.com/en/noticias
https://www.test.com/en/nouvelles
https://www.test.com/en/blog/hardware
https://www.test.com/en/news/hardware
Should be included - all other pages:
https://www.test.com/en/shop
https://www.test.com/en/shop/product-1/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}