$re = '/(?<!XXY)(?<=Y)\w(?=Y)(?!YYXX)/m';
$str = '(?<!XXY)(?<=Y)\\w(?=Y)(?!YYXX)
^ ^ ^ ^ ^
| | | | not before YYXX
| | |before Y
| |letter
| followed by Y
not followed by XXY
X0XYXYYX
X(?=Y) match X if before Y
X(?!Y) match X if not before Y
(?<=Y)X match X if followed by Y
(?<!Y)X match X if not followed by Y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);