using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!XXY)(?<=Y)\w(?=Y)(?!YYXX)";
string input = @"(?<!XXY)(?<=Y)\w(?=Y)(?!YYXX)
^ ^ ^ ^ ^
| | | | not before YYXX
| | |before Y
| |letter
| followed by Y
not followed by XXY
X0XYXYYX
X(?=Y) match X if before Y
X(?!Y) match X if not before Y
(?<=Y)X match X if followed by Y
(?<!Y)X match X if not followed by Y";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}