const regex = /(?<!XXY)(?<=Y)\w(?=Y)(?!YYXX)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!XXY)(?<=Y)\\w(?=Y)(?!YYXX)', 'gm')
const str = `(?<!XXY)(?<=Y)\\w(?=Y)(?!YYXX)
^ ^ ^ ^ ^
| | | | not before YYXX
| | |before Y
| |letter
| followed by Y
not followed by XXY
X0XYXYYX
X(?=Y) match X if before Y
X(?!Y) match X if not before Y
(?<=Y)X match X if followed by Y
(?<!Y)X match X if not followed by Y`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}