import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^h[1,3,5]\\-ars0(?:[1-5]\\-v|[6,7])\\.eset\\.com$";
final String string = "h1-ars01-v.eset.com\n"
+ "h1-ars02-v.eset.com\n"
+ "h1-ars03-v.eset.com\n"
+ "h1-ars04-v.eset.com\n"
+ "h1-ars05-v.eset.com\n\n"
+ "h1-ars06.eset.com\n"
+ "h1-ars07.eset.com\n\n"
+ "h3-ars01-v.eset.com\n"
+ "h3-ars02-v.eset.com\n"
+ "h3-ars03-v.eset.com\n"
+ "h3-ars04-v.eset.com\n"
+ "h3-ars05-v.eset.com\n\n"
+ "h3-ars06.eset.com\n"
+ "h3-ars07.eset.com\n\n"
+ "h5-ars01-v.eset.com\n"
+ "h5-ars02-v.eset.com\n"
+ "h5-ars03-v.eset.com\n"
+ "h5-ars04-v.eset.com\n"
+ "h5-ars05-v.eset.com\n\n"
+ "h5-ars06.eset.com\n"
+ "h5-ars07.eset.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}