#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^h[1,3,5]\-ars0(?:[1-5]\-v|[6,7])\.eset\.com$"
Local $sString = "h1-ars01-v.eset.com" & @CRLF & _
"h1-ars02-v.eset.com" & @CRLF & _
"h1-ars03-v.eset.com" & @CRLF & _
"h1-ars04-v.eset.com" & @CRLF & _
"h1-ars05-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h1-ars06.eset.com" & @CRLF & _
"h1-ars07.eset.com" & @CRLF & _
"" & @CRLF & _
"h3-ars01-v.eset.com" & @CRLF & _
"h3-ars02-v.eset.com" & @CRLF & _
"h3-ars03-v.eset.com" & @CRLF & _
"h3-ars04-v.eset.com" & @CRLF & _
"h3-ars05-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h3-ars06.eset.com" & @CRLF & _
"h3-ars07.eset.com" & @CRLF & _
"" & @CRLF & _
"h5-ars01-v.eset.com" & @CRLF & _
"h5-ars02-v.eset.com" & @CRLF & _
"h5-ars03-v.eset.com" & @CRLF & _
"h5-ars04-v.eset.com" & @CRLF & _
"h5-ars05-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h5-ars06.eset.com" & @CRLF & _
"h5-ars07.eset.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")