package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^h[1,3,5]\-ars0(?:[1-5]\-v|[6,7])\.eset\.com$`)
var str = `h1-ars01-v.eset.com
h1-ars02-v.eset.com
h1-ars03-v.eset.com
h1-ars04-v.eset.com
h1-ars05-v.eset.com
h1-ars06.eset.com
h1-ars07.eset.com
h3-ars01-v.eset.com
h3-ars02-v.eset.com
h3-ars03-v.eset.com
h3-ars04-v.eset.com
h3-ars05-v.eset.com
h3-ars06.eset.com
h3-ars07.eset.com
h5-ars01-v.eset.com
h5-ars02-v.eset.com
h5-ars03-v.eset.com
h5-ars04-v.eset.com
h5-ars05-v.eset.com
h5-ars06.eset.com
h5-ars07.eset.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}