// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Birthday\s*(.*)\sAge\s(.*)\s*Gender\s*(.*)").unwrap();
let string = "Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}