using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Birthday\s*(.*)\sAge\s(.*)\s*Gender\s*(.*)";
string input = @"Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}