const regex = /Birthday\s*(.*)\sAge\s(.*)\s*Gender\s*(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Birthday\\s*(.*)\\sAge\\s(.*)\\s*Gender\\s*(.*)', 'g')
const str = `Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}