$re = '/((\$?[A-Za-z_][A-Za-z_0-9.]*):)?([A-Za-z_][A-Za-z_0-9.]*)\(((.*,)*(.*))\)/m';
$str = 'str test = "ee";
call $std:console.print(test);
call $std:window.resize(1280, 720);
call test("test");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);