package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\$?[A-Za-z_][A-Za-z_0-9.]*):)?([A-Za-z_][A-Za-z_0-9.]*)\(((.*,)*(.*))\)`)
var str = `str test = "ee";
call $std:console.print(test);
call $std:window.resize(1280, 720);
call test("test");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}